This is a collaboratively edited question and answer site for power users of Plethra hardware and software. It's 100% free to participate.

No iTunes source

0 votes

I've got a Windows PC that's running the A|A software and also has itunes installed but I don't see itunes in the source list.

I've tried opening itunes before A|A and leaving it open but not sure if that's necessary. I've also tried restarting the A|A service. I've had a look in the config link and itunes isn't available in there either (not sure if it should be)

related to an answer for: Is there a way to use iTunes playlists?
asked Sep 20, 2016 by user1627 (35 points)
edited Nov 1, 2016 by user1
iTunes doesn't need to be running in order for audio|acacia to find and index your music.

How large of a library do you have? If its very large (100,000+ items) it will take longer before the library shows up in audio|acacia, but it shouldn't take more then a few minutes. If you have an older/slower PC, it will take a bit longer.

Do you see other music sources or speakers (default sound) originating from the same computer as this iTunes library? If you don't see anything from the computer, or the computer doesn't show up in the config|acacia interface, then there is a different problem at play.
The PC is an i5-3570 with 16GB of RAM so it's definitely not a slow machine but not top of the line either.

There's 7895 songs in the library so not massive but I left it overnight and it never found it.

I have added the same music as a media server and am able to play it from there but I assume I'd get playlists and extra features from having the itunes library directly available?

Unfortunately my trial has now expired so I can't test this further, is there any way to extend the trial?
Go ahead and submit a support ticket at ( ) so we can help you out.
I get a 404 when I click the link above.
Sorry about that. The link is fixed now. It was adding in the trailing ')' to the address.
Did this ever get resolved, I am having the same problem.  PC with windows 10, and config|acacia does see my music but just as a folder with music, not as itunes.  Is there a trick to get itunes to be recognized?
Does the below answer resolve your issue? If not, I'd recommend contacting support.

1 Answer

0 votes
Best answer

iTunes libraries not showing up can happen for three reasons:

  1. You installed iTunes after audio|acacia and have not restarted audio|acacia yet. This happens because we do not poll for new installs of iTunes.

  2. You installed iTunes before audio|acacia but forgot to share the XML with third party applications as stated in the setup guide.

  3. There is some other problem or bug that has yet to be reported. If you find yourself in this category you should report a bug or submit a support ticket.

answered Nov 27, 2016 by user1 (1,094 points)